Refer to the exhibit. An engineer must create a configuration that prevents R3 from receiving the LSA about 172.16.1.4/32. Which configuration set achieves this goal?
A.
On R3 ip access-list standard R4_L0 deny host 172.16.1.4 permit any router ospf 200 distribute-list R4_L0 in
B.
On R1 ip prefix-list INTO-AREA1 seq 5 deny 172.16.1.4/32 ip prefix-list INTO-AREA1 seq 10 permit 0.0.0.0/0 le 32 router ospf 200 area 1 filter-list prefix INTO-AREA1 out
C.
On R1 ip prefix-list INTO-AREA1 seq 5 deny 172.16.1.4/32 ip prefix-list INTO-AREA1 seq 10 permit 0.0.0.0/0 le 32 router ospf 200 area 1 filter-list prefix INTO-AREA1 in
D.
On R3 ip prefix-list INTO-AREA1 seq 5 deny 172.16.1.4/32 ip prefix-list INTO-AREA1 seq 10 permit 0.0.0.0/0 le 32 router ospf 200 area 1 filter-list prefix INTO-AREA1 in
Correct is C
The policy must be applied on R1 and we have 2 ways.
-Apply outbound area 0 (This will affect others areas in this ABR
-Apply inbound area 1 (More accurate)
Validate on EVE-NG
A.
On R3
ip access-list standard R4_L0
deny host 172.16.1.4
permit any
router ospf 200
distribute-list R4_L0 in
B.
On R1
ip prefix-list INTO-AREA1 seq 5 deny 172.16.1.4/32
ip prefix-list INTO-AREA1 seq 10 permit 0.0.0.0/0 le 32
router ospf 200
area 1 filter-list prefix INTO-AREA1 out
C.
On R1
ip prefix-list INTO-AREA1 seq 5 deny 172.16.1.4/32
ip prefix-list INTO-AREA1 seq 10 permit 0.0.0.0/0 le 32
router ospf 200
area 1 filter-list prefix INTO-AREA1 in
D.
On R3
ip prefix-list INTO-AREA1 seq 5 deny 172.16.1.4/32
ip prefix-list INTO-AREA1 seq 10 permit 0.0.0.0/0 le 32
router ospf 200
area 1 filter-list prefix INTO-AREA1 in
B is right,the R1 is an ABR router and when using filter list area 1, stop Advertising the LSA type from backbone to area 1 to OUT side
filter-list use for out , but you can use Dsitribute-list on both side.
We can filter using distribute-lists or IP-prefix lists.
A is incorrect, we can't filter LSA within the area.
B is incorrect, we need to filter routes being advertised to Area 1 (ingress direction)
D is also incorrect, we can't filter LSA within the area.
Filtering LSAs between areas on an ABR or ASBR is accepted.
https://networklessons.com/ospf/ospf-distribute-list-filtering
Answer is C.
Not sure if this reasoning is valid but. If the filter was applied outbound. Would the OSPF tree on R3 and R1 differ for Area 1? And all intra-area routers have to have the same routing information....
Router(config-router)# area area-id filter-list prefix prefix-list-name in
Configures the router to filter interarea routes into the specified area.
Router(config-router)# area area-id filter-list prefix prefix-list-name out
Configures the router to filter interarea routes out of the specified area.
so IN is for the area specified (in this case area 1) and out would be other except Area 1
Answer is C: at first i thought it was B, but the keywords in and out are a bit confusing without proper practice.
In the command: ospf area 2 filter-list INTO-AREA1
The option of "in" indicates networks going into the specified area
The option of "out" indicates networks coming from the specified area
I've done this in GNS3 to make sure I did understand correctly. Answer is C. However this isn't the only way to accomplish this. For me a better solution would have been to apply the prefix-list into R3 itself as a distribute-list prefix PREFIX in to deny the route coming into the R3 routing table.
Simulated the exact lab and found that the answer is C
the ABR will filter the subnet by not advertising it to the other routers in area 1. It will keep to itself thou
R3 should not receive the routes but R1 can receive the routes . To prevent R3 from getting the routes, R1 should filter the routes it nees to pass to R3 which is egress direction. b is correct
this is ABR, pay attention to 172.16.13.0/24 (this netw will be filtered)
cisco_R3(config-router)#do s runn | i PL_3
ip prefix-list PL_3 seq 10 deny 172.16.13.0/24
ip prefix-list PL_3 seq 20 permit 0.0.0.0/0 le 32
cisco_R3(config-router)#
cisco_R3(config-router)#area 22 filter-list prefix PL_3 ?
in Filter networks sent to this area <<<<<<<<<<<<<<<<<<<
out Filter networks sent from this area
cisco_R3(config-router)#area 22 filter-list prefix PL_3 in
cisco_R3(config-router)#
cisco_R3(config-router)#do s runn | s ospf
ip ospf 1 area 22
router ospf 1
area 22 filter-list prefix PL_3 in
passive-interface default
no passive-interface Ethernet0/0.10
no passive-interface Ethernet0/0.50
network 0.0.0.0 255.255.255.255 area 0
cisco_R3(config-router)#do s runn int Ethernet0/0.50
interface Ethernet0/0.50
encapsulation dot1Q 50
ip address 10.111.10.1 255.255.255.252
ip ospf 1 area 22
end
far-end GRT before filtering:
cisco_R5#show ip route ospf
3.0.0.0/32 is subnetted, 1 subnets
O IA 3.3.3.3 [110/11] via 10.111.10.1, 00:01:12, Ethernet0/0.50
172.16.0.0/24 is subnetted, 2 subnets
O IA 172.16.13.0 [110/20] via 10.111.10.1, 00:00:43, Ethernet0/0.50 <<<<<<<<<<<<<<<<<<<
O IA 172.16.113.0 [110/20] via 10.111.10.1, 00:01:12, Ethernet0/0.50
cisco_R5#
after - netw 172.16.13.0/24 disapeared:
cisco_R5#show ip route ospf
3.0.0.0/32 is subnetted, 1 subnets
O IA 3.3.3.3 [110/11] via 10.111.10.1, 00:06:23, Ethernet0/0.50
172.16.0.0/24 is subnetted, 2 subnets
O IA 172.16.113.0 [110/20] via 10.111.10.1, 00:06:23, Ethernet0/0.50
cisco_R5#
Correct answer b)
On R1 ip prefix-list INTO-AREA1 seq 5 deny 172.16.1.4/32 ip prefix-list INTO-AREA1 seq 10 permit 0.0.0.0/0 le 32 router ospf 200 area 1 filter-list prefix INTO-AREA1 out
R1 is the ABR.
A voting comment increases the vote count for the chosen answer by one.
Upvoting a comment with a selected answer will also increase the vote count towards that answer by one.
So if you see a comment that you already agree with, you can upvote it instead of posting a new comment.
Ferrantee
Highly Voted 2 years, 2 months agodragonwise
Highly Voted 1 year, 7 months agokamyarkav
Most Recent 1 month agoAbdullahMohammad251
2 months ago[Removed]
5 months, 2 weeks agoblack2jm
6 months, 3 weeks agoIgorLVG
6 months, 4 weeks ago[Removed]
1 year, 4 months ago[Removed]
1 year, 4 months agodragonwise
1 year, 7 months agobendarkel
1 year, 8 months agobendarkel
1 year, 8 months agobendarkel
1 year, 8 months agomarkymark874
1 year, 10 months agonushadu
1 year, 10 months agonushadu
1 year, 10 months agoH3kerman
1 year, 12 months agojjeans
1 year, 12 months agoTypovy
2 years agoAnarky19
2 years, 2 months agobendarkel
2 years, 1 month ago